<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<!-- Mafeel Code -->
<script>window.mrf={host:"b.marfeel.com",dt:3},function(e,t,o,a,i,r,n){function d(){l&&(e.cookie="fromt=yes;path=/;expires="+new Date(Date.now()+18e5).toGMTString(),o.reload())}var l=!/marfeelgarda=no|fromt=yes/i.test(r+";"+i);if((/(ipad.*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9](?!.*mobile)|\bSilk\b/i.test(a)&&2&n.dt||/(ip(hone|od).*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9].*mobile|bb10/i.test(a)&&1&n.dt||/marfeelgarda=off/i.test(r))&&t===t.top){l&&e.write('<plaintext style="display:none">');var s="script",m=setTimeout(d,1e4),c=e.createElement(s),f=e.getElementsByTagName(s)[0];c.src="//bc.marfeel.com/statics/marfeel/gardac.js",c.onerror=d,c.onload=function(){clearTimeout(m)},f.parentNode.insertBefore(c,f)}}(document,window,location,navigator.userAgent,document.cookie,location.search,window.mrf);</script>
<!-- End Mafeel Code -->

<meta property="fb:pages" content="103305193039107" />
<meta charset="UTF-8" />

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="pingback" href="https://www.thestandard.co.zw/xmlrpc.php" />

<!-- Always force latest IE rendering engine (even in intranet) & Chrome Frame -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />

<!--  Mobile viewport scale -->
<meta content="initial-scale=1.0, maximum-scale=1.0, user-scalable=yes" name="viewport"/>

<!-- This site is optimized with the Yoast SEO plugin v3.2.5 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Jah Prayzah retraces his roots - The Standard</title>
<link rel="canonical" href="https://www.thestandard.co.zw/2017/05/28/jah-prayzah-retraces-roots/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Jah Prayzah retraces his roots - The Standard" />
<meta property="og:description" content="THE Biblical saying that “blessed is the hand that giveth” aptly describes Uzumba-bred musician Jah Prayzah’s strong sense of social obligation and charity as he believes that it is always &hellip;" />
<meta property="og:url" content="https://www.thestandard.co.zw/2017/05/28/jah-prayzah-retraces-roots/" />
<meta property="og:site_name" content="The Standard" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Standard-Newspaper/103305193039107" />
<meta property="article:section" content="Entertainment" />
<meta property="article:published_time" content="2017-05-28T07:56:39+02:00" />
<meta property="article:modified_time" content="2017-05-27T17:11:27+02:00" />
<meta property="og:updated_time" content="2017-05-27T17:11:27+02:00" />
<meta property="og:image" content="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Jah-Prayzah-1.gif" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="400" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="THE Biblical saying that “blessed is the hand that giveth” aptly describes Uzumba-bred musician Jah Prayzah’s strong sense of social obligation and charity as he believes that it is always [&hellip;]" />
<meta name="twitter:title" content="Jah Prayzah retraces his roots - The Standard" />
<meta name="twitter:site" content="@thestandardzim" />
<meta name="twitter:image" content="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Jah-Prayzah-1.gif" />
<meta name="twitter:creator" content="@thestandardzim" />
<!-- / Yoast SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="The Standard &raquo; Feed" href="https://www.thestandard.co.zw/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Standard &raquo; Comments Feed" href="https://www.thestandard.co.zw/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Standard &raquo; Jah Prayzah retraces his roots Comments Feed" href="https://www.thestandard.co.zw/2017/05/28/jah-prayzah-retraces-roots/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"https:\/\/www.thestandard.co.zw\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.5.9"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='fsb-image-css'  href='https://www.thestandard.co.zw/wp-content/plugins/simple-full-screen-background-image/includes/fullscreen-image.css?ver=4.5.9' type='text/css' media='all' />
<link rel='stylesheet' id='wpusb-style-css'  href='https://www.thestandard.co.zw/wp-content/plugins/wpupper-share-buttons/assets/stylesheets/style.css?ver=3.12' type='text/css' media='all' />
<link rel='stylesheet' id='woodojo_tabs-css'  href='https://www.thestandard.co.zw/wp-content/plugins/woodojo/bundled/woodojo-tabs/assets/css/style.css?ver=4.5.9' type='text/css' media='all' />
<link rel='stylesheet' id='theme-stylesheet-css'  href='https://www.thestandard.co.zw/wp-content/themes/thestandard-child/style.css?ver=5.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='woo-layout-css'  href='https://www.thestandard.co.zw/wp-content/themes/thestandard-child/css/layout.css?ver=4.5.9' type='text/css' media='all' />
<link rel='stylesheet' id='ad_module_css-css'  href='https://www.thestandard.co.zw/wp-content/plugins/ad-module/css/ads.min.css?ver=4.5.9' type='text/css' media='all' />
<!--[if lt IE 9]>
<link href="https://www.thestandard.co.zw/wp-content/themes/canvas/css/non-responsive.css" rel="stylesheet" type="text/css" />
<style type="text/css">.col-full, #wrapper { width: 980px; max-width: 980px; } #inner-wrapper { padding: 0; } body.full-width #header, #nav-container, body.full-width #content, body.full-width #footer-widgets, body.full-width #footer { padding-left: 0; padding-right: 0; } body.fixed-mobile #top, body.fixed-mobile #header-container, body.fixed-mobile #footer-container, body.fixed-mobile #nav-container, body.fixed-mobile #footer-widgets-container { min-width: 980px; padding: 0 1em; } body.full-width #content { width: auto; padding: 0 1em;}</style>
<![endif]-->
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-content/plugins/woodojo/bundled/woodojo-tabs/assets/js/functions.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-content/themes/canvas/includes/js/third-party.js?ver=4.5.9'></script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-content/themes/canvas/includes/js/modernizr.js?ver=2.6.2'></script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-content/themes/canvas/includes/js/general.js?ver=4.5.9'></script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-includes/js/swfobject.js?ver=2.2-20120417'></script>

<!-- Adjust the website width -->
<style type="text/css">
	.col-full, #wrapper { max-width: 980px !important; }
</style>

<link rel='https://api.w.org/' href='https://www.thestandard.co.zw/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thestandard.co.zw/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thestandard.co.zw/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.thestandard.co.zw/?p=210006720943863' />
<link rel="alternate" type="application/json+oembed" href="https://www.thestandard.co.zw/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thestandard.co.zw/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.15.3 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-2 { margin:0px;width:100%; max-width:300px; height:100%; max-height:300px; }
	.g-3 { margin:0px;width:100%; max-width:300px; height:100%; max-height:600px; }
	.g-4 { margin:0px;width:100%; max-width:768px; height:100%; max-height:90px; }
	.g-5 { margin:0px;width:100%; max-width:500px; height:100%; max-height:90px; }
	.g-6 { margin:0px;width:100%; max-width:500px; height:100%; max-height:90px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<!--script type="text/javascript"> 
window._taboola = window._taboola || []; 
_taboola.push({article:'auto'}); 
!function (e, f, u) { 
e.async = 1; 
e.src = u; 
f.parentNode.insertBefore(e, f); 
}(document.createElement('script'), 
document.getElementsByTagName('script')[0], 
'https://cdn.taboola.com/libtrc/alphamedia-thestandard/loader.js'); 
</script--!>

<!-- Options Panel Custom CSS -->
<style type="text/css">
body .sd-social-icon .sd-content li.share-custom a span, body .sd-social-icon-text .sd-content li.share-custom a span, body .sd-social-text .sd-content li.share-custom a span, body .sd-social-official .sd-content li.share-custom a span, body .sd-content ul li.share-custom a.share-icon span {

background-size: 11px 11px !important;

}
</style>


<!-- Woo Shortcodes CSS -->
<link href="https://www.thestandard.co.zw/wp-content/themes/canvas/functions/css/shortcodes.css" rel="stylesheet" type="text/css" />

<!-- Theme version -->
<meta name="generator" content="The Zimbabwe Independent Child Theme 2.0" />
<meta name="generator" content="Canvas 5.5.3" />
<meta name="generator" content="WooFramework 6.2.6" />

<!-- Google Webfonts -->
<link href="https://fonts.googleapis.com/css?family=PT+Serif%3Aregular%2C%3Aitalic%2C%3A700%2C%3A700italic" rel="stylesheet" type="text/css" />
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/13427547/STD01', [300, 100], 'div-gpt-ad-1421410767514-0').addService(googletag.pubads());
googletag.defineSlot('/13427547/STD02', [300, 250], 'div-gpt-ad-1421410767514-1').addService(googletag.pubads());
googletag.defineSlot('/13427547/STD03', [300, 600], 'div-gpt-ad-1421410767514-2').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>


<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>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</script>
<meta name="inmobi-site-verification" content="ecc90496f0f5196892679da517611b08">





<script type='text/javascript'>
  (function() {
    var useSSL = 'https:' == document.location.protocol;
    var src = (useSSL ? 'https:' : 'http:') +
        '//www.googletagservices.com/tag/js/gpt.js';
    document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineOutOfPageSlot('/13427547/Newsday_Wallpaper', 'div-gpt-ad-1439375835448-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().enableSyncRendering();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-5185228015030174",
    enable_page_level_ads: true
  });
</script></head>
<body class="single single-post postid-210006720943863 single-format-standard chrome alt-style-default boxed-layout two-col-left width-980 two-col-left-980">
	<script type="text/javascript">
	  (function() {
	    var em = document.createElement('script'); em.type = 'text/javascript'; em.async = true;
	    em.src = ('https:' == document.location.protocol ? 'https://za-ssl' : 'http://za-cdn') + '.effectivemeasure.net/em.js';
	    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(em, s);
	  })();
	</script>
	<noscript>
	<img src="//za.effectivemeasure.net/em_image" alt="" style="position:absolute; left:-5px;" />
	</noscript>
		<script type="text/javascript">

	  var _gaq = _gaq || [];
	  _gaq.push(['_setAccount', 'UA-33262148-2']);
	  _gaq.push(['_trackPageview']);

	  (function() {
	    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
	    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
	    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	  })();

	</script>
		<div id="top">
		<div class="col-full">
			<h3 class="top-menu">Top Menu</h3><ul id="top-nav" class="nav top-navigation fl"><li id="menu-item-56363" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56363"><a href="https://www.thestandard.co.zw/about-us/">About us</a></li>
<li id="menu-item-56361" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56361"><a href="https://www.thestandard.co.zw/advertise/">Advertise</a></li>
<li id="menu-item-56364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56364"><a href="https://www.thestandard.co.zw/subscribe/">Subscribe</a></li>
<li id="menu-item-78531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78531"><a href="https://www.thestandard.co.zw/family/">Family</a></li>
<li id="menu-item-56362" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56362"><a href="https://www.thestandard.co.zw/contact-us/">Contact us</a></li>
</ul>		</div>
	</div><!-- /#top -->
<div id="wrapper">

	<div id="inner-wrapper">

	<!-- Error, Ad is not available at this time due to schedule/geolocation restrictions! -->  
 <br/>
 <div style="display:inline-block; "> <div class="lolo" style="display:inline-block; width: 49%; "><div class="g g-5"><div class="g-dyn a-45 c-1"><a href="http://www.posb.co.zw" target="_blank"><img src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/POSB-MoneyGram-Online-Newsday.gif" /></a></div><div class="g-dyn a-35 c-2"><a href="http://www.telecel.co.zw/products-services/promotions/280-megaboost target="_blank"><img src="https://www.thestandard.co.zw/wp-content/uploads/2017/03/TELECEL-NEW.jpg" /></a></div></div></div>
 <div class="lolo" style="display:inline-block; width: 49%; float:right;"><div class="g g-6"><div class="g-dyn a-45 c-1"><a href="http://www.posb.co.zw" target="_blank"><img src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/POSB-MoneyGram-Online-Newsday.gif" /></a></div><div class="g-dyn a-35 c-2"><a href="http://www.telecel.co.zw/products-services/promotions/280-megaboost target="_blank"><img src="https://www.thestandard.co.zw/wp-content/uploads/2017/03/TELECEL-NEW.jpg" /></a></div></div></div></div>
<p/>
<br/>
<h3 class="nav-toggle icon"><a href="#navigation">Navigation</a></h3>

	<header id="header" class="col-full">

		<div id="logo">
<a href="https://www.thestandard.co.zw/" title="Zimbabwe&#039;s Leading Sunday Newspaper"><img src="https://www.thestandard.co.zw/wp-content/uploads/2014/06/Standard-Logo1.jpg" alt="The Standard" /></a>
</div>
	<div class="social-search">	        
    	<form method="get" class="searchform" action="https://www.thestandard.co.zw/" >
    		<input type="text" class="field s" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}" />
    		<input type="image" src="https://www.thestandard.co.zw/wp-content/themes/canvas/images/ico-search.png" alt="Search" class="submit" name="submit" />
    	</form>  	  
    	<a class="facebook" href="http://www.facebook.com/pages/The-Standard-Newspaper/103305193039107"></a>
    	<a class="twitter" href="https://twitter.com/thestandardzim"></a>
    	<a class="rss" href="https://www.thestandard.co.zw/feed/"></a>
    </div>
    <div class="fix"></div> 
    
	</header>
	<nav id="navigation" class="col-full" role="navigation">

	<section class="menus">

		<a href="https://www.thestandard.co.zw" class="nav-home"><span>Home</span></a>

	<h3>Primary Menu</h3><ul id="main-nav" class="nav fl"><li id="menu-item-55515" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-55515"><a href="http://www.thestandard.co.zw/">Home</a></li>
<li id="menu-item-53580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53580"><a href="https://www.thestandard.co.zw/local-zimbabwe-stories/">Local News</a></li>
<li id="menu-item-79585" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-79585"><a href="https://www.thestandard.co.zw/entertainment/">Entertainment</a></li>
<li id="menu-item-79687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79687"><a href="https://www.thestandard.co.zw/sports/">Sport</a></li>
<li id="menu-item-53584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53584"><a href="https://www.thestandard.co.zw/opinion/">Opinion</a></li>
<li id="menu-item-53585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53585"><a href="https://www.thestandard.co.zw/editorial/">Editorial</a></li>
<li id="menu-item-210006720925719" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210006720925719"><a href="https://www.thestandard.co.zw/standard-style/">Standard Style</a></li>
<li id="menu-item-210006720933880" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-210006720933880"><a href="http://www.myclassifieds.co.zw">MyClassifieds</a></li>
</ul>
	</section><!-- /.menus -->

	<a href="#top" class="nav-close"><span>Return to Content</span></a>

</nav>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SE_Menu -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:15px"
     data-ad-client="ca-pub-5185228015030174"
     data-ad-slot="1636720868"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>       
    <!-- #content Starts -->
	    <div id="content" class="col-full">
    
    	<div id="main-sidebar-container">    

            <!-- #main Starts -->
                        <section id="main">                       
<div class="breadcrumb breadcrumbs woo-breadcrumbs"><div class="breadcrumb-trail"><span class="trail-before"><span class="breadcrumb-title">You are here:</span></span> <a href="https://www.thestandard.co.zw" title="The Standard" rel="home" class="trail-begin">Home</a> <span class="sep">›</span> <a href="https://www.thestandard.co.zw/entertainment/" title="View Entertainment">Entertainment</a> <span class="sep">›</span> <a href="https://www.thestandard.co.zw/life-style/" title="View Life &amp; Style">Life &amp; Style</a> <span class="sep">›</span> <span class="trail-end">Jah Prayzah retraces his roots</span></div></div><article class="post-210006720943863 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-life-style">
	<header>
	<h1 class="title">Jah Prayzah retraces his roots</h1>	</header>
<div class="post-meta"><abbr class="date time published" title="2017-05-28T07:56:39+0200">May 28, 2017</abbr>  <span class="small">in</span> <span class="categories"><a href="https://www.thestandard.co.zw/entertainment/" title="View all items in Entertainment">Entertainment</a>, <a href="https://www.thestandard.co.zw/life-style/" title="View all items in Life &amp; Style">Life &amp; Style</a></span>   </div>
	<section class="entry">
			<div data-element-url="https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F"
			     data-tracking=""
			     data-attr-reference="210006720943863"
			     data-attr-nonce="0d3c8c6db5"
		     	 data-attr-nonce-gplus="ef93bd8e9d"
			     data-wpusb-component="counter-social-share"
			     class="wpusb wpusb-square  "
			     
			     >			<div class="wpusb-item wpusb-facebook " >

				<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Share on Facebook"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-facebook-square "></i>
				   <span data-title="Share"></span>
				</a>
				<span data-element="facebook" class="wpusb-count"></span>
			</div>			<div class="wpusb-item wpusb-twitter " >

				<a href="https://twitter.com/share?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&text=I just saw%20Jah%20Prayzah%20retraces%20his%20roots%20-%20Click to see also%20☛%20" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Tweet"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-twitter-square "></i>
				   <span data-title="Tweet"></span>
				</a>
				<span data-element="twitter" class="wpusb-count"></span>
			</div>			<div class="wpusb-item wpusb-linkedin " >

				<a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&title=Jah%20Prayzah%20retraces%20his%20roots" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Share on Linkedin"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-linkedin-square "></i>
				   <span data-title="Share"></span>
				</a>
				<span data-element="linkedin" class="wpusb-count"></span>
			</div>			<div class="wpusb-item wpusb-whatsapp " >

				<a href="whatsapp://send?text=Jah%20Prayzah%20retraces%20his%20roots%20☛%20https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Share on WhatsApp"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-whatsapp-square "></i>
				   <span data-title="Share"></span>
				</a>
				
			</div>			<div class="wpusb-item wpusb-email " >

				<a href="mailto:?subject=Jah%20Prayzah%20retraces%20his%20roots&body=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F
%0A%0AJah%20Prayzah%20retraces%20his%20roots%0A%0ATHE%20Biblical%20saying%20that%20%E2%80%9Cblessed%20is%20the%20hand%20that%20giveth%E2%80%9D%20aptly%20describes%20Uzumba-bred%20musician%20Jah%20Prayzah%E2%80%99s%20strong%20sense%20of%20social%20obligation%20and%20charity%20as%20he%20believes%20that%20it%20is%20always%20better%20to%20give%20than%20to%20receive.%0D%0A%0D%0ABY%20WINSTONE%20ANTONIO%0D%0A%0D%0A%0D%0A%0D%0AThe%20highflying%20dreadlocked%20singer%20last%20week%20proved%20that%20society%20deserves%20more%20from%20him%20than%20his%20music.%0D%0A%0D%0AIn%20a%20true%20reflection%20of%20that%2C%20there%20was%20pomp%20and%20funfair%20last%20Saturday%20at%20Musanhi%20Secondary%20School%20in%20Uzumbain%20Mashonaland%20East%20as%20Jah%20Prayzah%20brought%20smiles%20to%20pupils%20at%20his%20former%20school%20and%20surrounding%20areas%20when%20he%20launched%20the%20Tadzoka%20Kumusha%20Soccer%20tournament.%0D%0A%0D%0A%0D%0A%0D%0AFor%20such%20a%20day%2C%20the%20singer%20could%20have%20pocketed%20a%20decent%20package%20for%20a%20performance%2C%20but%20instead%2C%20he%20dedicated%20time%20to%20be%20in%20his%20rural%20area%20for%20a%20social%20responsibility%20gesture.%0D%0A%0D%0AIt%20is%20not%20Jah%20Prayzah%E2%80%99s%20launch%20of%20the%20tournament%20that%20will%20go%20a%20long%20way%20in%20the%20school%E2%80%99s%20history%2C%20but%20also%20his%20pledge%20to%20build%20a%20computer%20laboratory%20that%20would%20cost%20%2430%20000.%0D%0A%0D%0A%E2%80%9CThis%20is%20just%20my%20way%20to%20give%20back%20to%20the%20school%20that%20contributed%20a%20lot%20to%20who%20I%20am%20today%2C%E2%80%9D%20Jah%20Prayzah%20said.%20%0D%0A%0D%0A%0D%0A%0D%0A%E2%80%9CI%20know%20that%20there%20are%20lot%20of%20other%20things%20that%20are%20needed%20by%20the%20school%2C%20but%20I%20decided%20to%20start%20with%20this%20project%20set%20to%20start%20early%20June.%20God%20permitting%2C%20we%20can%20develop%20other%20areas%20in%20the%20future.%E2%80%9D%20%0D%0A%0D%0AIt%20was%20an%20electric%20atmosphere%20at%20the%20tournament%20that%20was%20held%20on%20a%20knock-out%20format%20and%20featured%20four%20teams%20%E2%80%94%20%20Mugabe%20Secondary%20School%2C%20Rudairo%20Secondary%20School%2C%20Nyamhara%20Secondary%20School%20and%20the%20host%20Musanhi%20Secondary%2C%20who%20were%20later%20crowned%20the%20champions.%0D%0A%0D%0AThe%20event%20was%20attended%20by%20Member%20of%20Parliament%20for%20Uzumba%2C%20Simbaneuta%20Mudarikwa%2C%20traditional%20chiefs%2C%20civic%20leaders%20and%20veteran%20sports%20commentator%20Charles%20Mabika%2C%20who%20did%20the%20commentary%20of%20the%20final%20match%20of%20the%20tournament.%0D%0A%0D%0AIn%20an%20interview%20on%20the%20sidelines%20of%20the%20event%2C%20the%20Mdhara%20Vachauya%20hitmaker%20said%20more%20projects%20under%20the%20Tadzoka%20Kumusha%20initiative%20were%20in%20the%20pipeline%20%20as%20he%20endeavours%20to%20make%20a%20better%20tomorrow%20for%20everyone%20in%20his%20rural%20community%20and%20Africa%20at%20large.%0D%0A%0D%0A%0D%0A%0D%0ACommunity%20and%20traditional%20leaders%20hailed%20Jah%20Prayzah%20for%20the%20gesture%2C%20saying%20the%20musician%20was%20a%20true%20role%20model%20in%20Uzumba.%0D%0A%0D%0AJah%20Prayzah%20said%20it%20was%20a%20dream%20come%20true%20to%20host%20the%20tournament%20after%20months%20of%20planning.%0D%0A%0D%0A%E2%80%9CGiving%20back%20to%20a%20community%20and%20the%20people%20who%20paved%20the%20way%20for%20you%20is%20always%20a%20joy.%20I%20am%20really%20honoured%20to%20host%20the%20first%20of%20many%20Jah%20Prayzah%20soccer%20tournaments%20for%20schools%20here.%20I%20have%20always%20dreamt%20of%20the%20day%20I%20would%20get%20to%20spend%20time%20with%20the%20kids.%20It%20is%20my%20hope%20and%20wish%20that%20one%20or%20two%20of%20them%20will%20be%20inspired%20to%20take%20this%20initiative%20further%20when%20they%20grow%20up%2C%E2%80%9D%20he%20said.%0D%0A%0D%0A%E2%80%9CThe%20smiles%20on%20the%20kids%E2%80%99%20faces%20will%20definitely%20push%20for%20more%20works%20and%20projects%20from%20us%20for%20them.%20Like%20the%20saying%20goes%2C%20%E2%80%98honour%20your%20father%20and%20mother%20so%20that%20your%20days%20on%20earth%20may%20be%20increased%E2%80%99.%20For%20us%2C%20it%20is%20not%20only%20limited%20to%20your%20parents%2C%20but%20basically%20where%20you%20come%20from%20and%20just%20remembering%20your%20roots.%E2%80%9D%0D%0A%0D%0A%0D%0A%0D%0AMudarikwa%20saluted%20Jah%20Prayzah%20and%20urged%20the%20pupils%20to%20emulate%20what%20the%20dreadlocked%20musician%20did%20for%20the%20community.%0D%0A%0D%0A%E2%80%9CJah%20Prayzah%20is%20a%20product%20of%20this%20school%20and%20I%20want%20to%20thank%20him%20for%20such%20an%20initiative%20as%20he%20has%20remembered%20the%20importance%20of%20his%20former%20school%20at%20a%20time%20when%20many%20of%20the%20former%20students%20have%20not%20returned%20back%2C%E2%80%9D%20he%20said.%0D%0A%0D%0AHe%20challenged%20pupils%20to%20take%20sports%20seriously%20and%20desist%20from%20taking%20drugs%2C%20which%20he%20said%20destroys%20their%20future.%0A" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Send by email"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-email-square "></i>
				   <span data-title="Email"></span>
				</a>
				
			</div>			<div class="wpusb-item wpusb-printer " >

				<a href="http://www.printfriendly.com/print?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Print via PrintFriendly"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-printer-square "></i>
				   <span data-title="Print"></span>
				</a>
				
			</div></div><p>THE Biblical saying that “blessed is the hand that giveth” aptly describes Uzumba-bred musician Jah Prayzah’s strong sense of social obligation and charity as he believes that it is always better to give than to receive.<span id="more-210006720943863"></span></p>
<p><strong>BY WINSTONE ANTONIO</strong></p>
<p><img src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Jah-Prayzah-1.gif" alt="Jah-Prayzah-1" width="600" height="400" class="alignnone size-full wp-image-210006720943865" /></p>
<p>The highflying dreadlocked singer last week proved that society deserves more from him than his music.</p>
<p>In a true reflection of that, there was pomp and funfair last Saturday at Musanhi Secondary School in Uzumbain Mashonaland East as Jah Prayzah brought smiles to pupils at his former school and surrounding areas when he launched the Tadzoka Kumusha Soccer tournament.</p>
<p><img src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Jah-Prayzah-2.gif" alt="Jah-Prayzah-2" width="600" height="400" class="alignnone size-full wp-image-210006720943866" /></p>
<p>For such a day, the singer could have pocketed a decent package for a performance, but instead, he dedicated time to be in his rural area for a social responsibility gesture.</p>
<p>It is not Jah Prayzah’s launch of the tournament that will go a long way in the school’s history, but also his pledge to build a computer laboratory that would cost $30 000.</p>
<p>“This is just my way to give back to the school that contributed a lot to who I am today,” Jah Prayzah said. </p>
<p><img src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Jah-Prayzah-3.gif" alt="Jah-Prayzah-3" width="600" height="400" class="alignnone size-full wp-image-210006720943867" /></p>
<p>“I know that there are lot of other things that are needed by the school, but I decided to start with this project set to start early June. God permitting, we can develop other areas in the future.” </p>
<p>It was an electric atmosphere at the tournament that was held on a knock-out format and featured four teams —  Mugabe Secondary School, Rudairo Secondary School, Nyamhara Secondary School and the host Musanhi Secondary, who were later crowned the champions.</p>
<p>The event was attended by Member of Parliament for Uzumba, Simbaneuta Mudarikwa, traditional chiefs, civic leaders and veteran sports commentator Charles Mabika, who did the commentary of the final match of the tournament.</p>
<p>In an interview on the sidelines of the event, the Mdhara Vachauya hitmaker said more projects under the Tadzoka Kumusha initiative were in the pipeline  as he endeavours to make a better tomorrow for everyone in his rural community and Africa at large.</p>
<p><img src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Jah-Prayzah-4.gif" alt="Jah-Prayzah-4" width="600" height="400" class="alignnone size-full wp-image-210006720943868" /></p>
<p>Community and traditional leaders hailed Jah Prayzah for the gesture, saying the musician was a true role model in Uzumba.</p>
<p>Jah Prayzah said it was a dream come true to host the tournament after months of planning.</p>
<p>“Giving back to a community and the people who paved the way for you is always a joy. I am really honoured to host the first of many Jah Prayzah soccer tournaments for schools here. I have always dreamt of the day I would get to spend time with the kids. It is my hope and wish that one or two of them will be inspired to take this initiative further when they grow up,” he said.</p>
<p>“The smiles on the kids’ faces will definitely push for more works and projects from us for them. Like the saying goes, ‘honour your father and mother so that your days on earth may be increased’. For us, it is not only limited to your parents, but basically where you come from and just remembering your roots.”</p>
<p><img src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Jah-Prayzah-5.gif" alt="Jah-Prayzah-5" width="600" height="400" class="alignnone size-full wp-image-210006720943869" /></p>
<p>Mudarikwa saluted Jah Prayzah and urged the pupils to emulate what the dreadlocked musician did for the community.</p>
<p>“Jah Prayzah is a product of this school and I want to thank him for such an initiative as he has remembered the importance of his former school at a time when many of the former students have not returned back,” he said.</p>
<p>He challenged pupils to take sports seriously and desist from taking drugs, which he said destroys their future.</p>
<div id='taboola-below-article-thumbnails'></div> 
<script type='text/javascript'> 
window._taboola = window._taboola || []; 
_taboola.push({ 
mode: 'thumbnails-a', 
container: 'taboola-below-article-thumbnails', 
placement: 'Below Article Thumbnails', 
target_type: 'mix' 
}); 
</script>			<div data-element-url="https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F"
			     data-tracking=""
			     data-attr-reference="210006720943863"
			     data-attr-nonce="0d3c8c6db5"
		     	 data-attr-nonce-gplus="ef93bd8e9d"
			     data-wpusb-component="counter-social-share"
			     class="wpusb wpusb-square  "
			     
			     >			<div class="wpusb-item wpusb-facebook " >

				<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Share on Facebook"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-facebook-square "></i>
				   <span data-title="Share"></span>
				</a>
				<span data-element="facebook" class="wpusb-count"></span>
			</div>			<div class="wpusb-item wpusb-twitter " >

				<a href="https://twitter.com/share?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&text=I just saw%20Jah%20Prayzah%20retraces%20his%20roots%20-%20Click to see also%20☛%20" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Tweet"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-twitter-square "></i>
				   <span data-title="Tweet"></span>
				</a>
				<span data-element="twitter" class="wpusb-count"></span>
			</div>			<div class="wpusb-item wpusb-linkedin " >

				<a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&title=Jah%20Prayzah%20retraces%20his%20roots" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Share on Linkedin"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-linkedin-square "></i>
				   <span data-title="Share"></span>
				</a>
				<span data-element="linkedin" class="wpusb-count"></span>
			</div>			<div class="wpusb-item wpusb-whatsapp " >

				<a href="whatsapp://send?text=Jah%20Prayzah%20retraces%20his%20roots%20☛%20https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Share on WhatsApp"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-whatsapp-square "></i>
				   <span data-title="Share"></span>
				</a>
				
			</div>			<div class="wpusb-item wpusb-email " >

				<a href="mailto:?subject=Jah%20Prayzah%20retraces%20his%20roots&body=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F
%0A%0AJah%20Prayzah%20retraces%20his%20roots%0A%0ATHE%20Biblical%20saying%20that%20%E2%80%9Cblessed%20is%20the%20hand%20that%20giveth%E2%80%9D%20aptly%20describes%20Uzumba-bred%20musician%20Jah%20Prayzah%E2%80%99s%20strong%20sense%20of%20social%20obligation%20and%20charity%20as%20he%20believes%20that%20it%20is%20always%20better%20to%20give%20than%20to%20receive.%0D%0A%0D%0ABY%20WINSTONE%20ANTONIO%0D%0A%0D%0A%0D%0A%0D%0AThe%20highflying%20dreadlocked%20singer%20last%20week%20proved%20that%20society%20deserves%20more%20from%20him%20than%20his%20music.%0D%0A%0D%0AIn%20a%20true%20reflection%20of%20that%2C%20there%20was%20pomp%20and%20funfair%20last%20Saturday%20at%20Musanhi%20Secondary%20School%20in%20Uzumbain%20Mashonaland%20East%20as%20Jah%20Prayzah%20brought%20smiles%20to%20pupils%20at%20his%20former%20school%20and%20surrounding%20areas%20when%20he%20launched%20the%20Tadzoka%20Kumusha%20Soccer%20tournament.%0D%0A%0D%0A%0D%0A%0D%0AFor%20such%20a%20day%2C%20the%20singer%20could%20have%20pocketed%20a%20decent%20package%20for%20a%20performance%2C%20but%20instead%2C%20he%20dedicated%20time%20to%20be%20in%20his%20rural%20area%20for%20a%20social%20responsibility%20gesture.%0D%0A%0D%0AIt%20is%20not%20Jah%20Prayzah%E2%80%99s%20launch%20of%20the%20tournament%20that%20will%20go%20a%20long%20way%20in%20the%20school%E2%80%99s%20history%2C%20but%20also%20his%20pledge%20to%20build%20a%20computer%20laboratory%20that%20would%20cost%20%2430%20000.%0D%0A%0D%0A%E2%80%9CThis%20is%20just%20my%20way%20to%20give%20back%20to%20the%20school%20that%20contributed%20a%20lot%20to%20who%20I%20am%20today%2C%E2%80%9D%20Jah%20Prayzah%20said.%20%0D%0A%0D%0A%0D%0A%0D%0A%E2%80%9CI%20know%20that%20there%20are%20lot%20of%20other%20things%20that%20are%20needed%20by%20the%20school%2C%20but%20I%20decided%20to%20start%20with%20this%20project%20set%20to%20start%20early%20June.%20God%20permitting%2C%20we%20can%20develop%20other%20areas%20in%20the%20future.%E2%80%9D%20%0D%0A%0D%0AIt%20was%20an%20electric%20atmosphere%20at%20the%20tournament%20that%20was%20held%20on%20a%20knock-out%20format%20and%20featured%20four%20teams%20%E2%80%94%20%20Mugabe%20Secondary%20School%2C%20Rudairo%20Secondary%20School%2C%20Nyamhara%20Secondary%20School%20and%20the%20host%20Musanhi%20Secondary%2C%20who%20were%20later%20crowned%20the%20champions.%0D%0A%0D%0AThe%20event%20was%20attended%20by%20Member%20of%20Parliament%20for%20Uzumba%2C%20Simbaneuta%20Mudarikwa%2C%20traditional%20chiefs%2C%20civic%20leaders%20and%20veteran%20sports%20commentator%20Charles%20Mabika%2C%20who%20did%20the%20commentary%20of%20the%20final%20match%20of%20the%20tournament.%0D%0A%0D%0AIn%20an%20interview%20on%20the%20sidelines%20of%20the%20event%2C%20the%20Mdhara%20Vachauya%20hitmaker%20said%20more%20projects%20under%20the%20Tadzoka%20Kumusha%20initiative%20were%20in%20the%20pipeline%20%20as%20he%20endeavours%20to%20make%20a%20better%20tomorrow%20for%20everyone%20in%20his%20rural%20community%20and%20Africa%20at%20large.%0D%0A%0D%0A%0D%0A%0D%0ACommunity%20and%20traditional%20leaders%20hailed%20Jah%20Prayzah%20for%20the%20gesture%2C%20saying%20the%20musician%20was%20a%20true%20role%20model%20in%20Uzumba.%0D%0A%0D%0AJah%20Prayzah%20said%20it%20was%20a%20dream%20come%20true%20to%20host%20the%20tournament%20after%20months%20of%20planning.%0D%0A%0D%0A%E2%80%9CGiving%20back%20to%20a%20community%20and%20the%20people%20who%20paved%20the%20way%20for%20you%20is%20always%20a%20joy.%20I%20am%20really%20honoured%20to%20host%20the%20first%20of%20many%20Jah%20Prayzah%20soccer%20tournaments%20for%20schools%20here.%20I%20have%20always%20dreamt%20of%20the%20day%20I%20would%20get%20to%20spend%20time%20with%20the%20kids.%20It%20is%20my%20hope%20and%20wish%20that%20one%20or%20two%20of%20them%20will%20be%20inspired%20to%20take%20this%20initiative%20further%20when%20they%20grow%20up%2C%E2%80%9D%20he%20said.%0D%0A%0D%0A%E2%80%9CThe%20smiles%20on%20the%20kids%E2%80%99%20faces%20will%20definitely%20push%20for%20more%20works%20and%20projects%20from%20us%20for%20them.%20Like%20the%20saying%20goes%2C%20%E2%80%98honour%20your%20father%20and%20mother%20so%20that%20your%20days%20on%20earth%20may%20be%20increased%E2%80%99.%20For%20us%2C%20it%20is%20not%20only%20limited%20to%20your%20parents%2C%20but%20basically%20where%20you%20come%20from%20and%20just%20remembering%20your%20roots.%E2%80%9D%0D%0A%0D%0A%0D%0A%0D%0AMudarikwa%20saluted%20Jah%20Prayzah%20and%20urged%20the%20pupils%20to%20emulate%20what%20the%20dreadlocked%20musician%20did%20for%20the%20community.%0D%0A%0D%0A%E2%80%9CJah%20Prayzah%20is%20a%20product%20of%20this%20school%20and%20I%20want%20to%20thank%20him%20for%20such%20an%20initiative%20as%20he%20has%20remembered%20the%20importance%20of%20his%20former%20school%20at%20a%20time%20when%20many%20of%20the%20former%20students%20have%20not%20returned%20back%2C%E2%80%9D%20he%20said.%0D%0A%0D%0AHe%20challenged%20pupils%20to%20take%20sports%20seriously%20and%20desist%20from%20taking%20drugs%2C%20which%20he%20said%20destroys%20their%20future.%0A" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Send by email"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-email-square "></i>
				   <span data-title="Email"></span>
				</a>
				
			</div>			<div class="wpusb-item wpusb-printer " >

				<a href="http://www.printfriendly.com/print?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
				   data-action="open-popup"
				   class="wpusb-button "
				   title="Print via PrintFriendly"
				   
				   rel="nofollow">

				   <i class="wpusb-icon-printer-square "></i>
				   <span data-title="Print"></span>
				</a>
				
			</div></div>	</section><!-- /.entry -->
	<div class="fix"></div>
		<aside id="connect">
		<h3>Subscribe</h3>

		<div class="col-left">
			<p>Subscribe to our e-mail newsletter to receive updates.</p>

			
						<!-- Begin MailChimp Signup Form -->
			<div id="mc_embed_signup">
				<form class="newsletter-form" action="http://us5.list-manage.com/subscribe/post?u=6a6a52494ae71836f4d9e40f8&id=ffb9f07a68" method="post" target="popupwindow" onsubmit="window.open('http://us5.list-manage.com/subscribe/post?u=6a6a52494ae71836f4d9e40f8&id=ffb9f07a68', 'popupwindow', 'scrollbars=yes,width=650,height=520');return true">
					<input type="text" name="EMAIL" class="required email" value="E-mail"  id="mce-EMAIL" onfocus="if (this.value == 'E-mail') {this.value = '';}" onblur="if (this.value == '') {this.value = 'E-mail';}">
					<input type="submit" value="Submit" name="subscribe" id="mc-embedded-subscribe" class="btn submit button">
				</form>
			</div>
			<!--End mc_embed_signup-->
			
						<div class="social">
		   				   		<a href="https://www.thestandard.co.zw/feed/" class="subscribe" title="RSS"></a>

		   				   		<a target="_blank" href="https://twitter.com/thestandardzim" class="twitter" title="Twitter"></a>

		   				   		<a target="_blank" href="http://www.facebook.com/pages/The-Standard-Newspaper/103305193039107" class="facebook" title="Facebook"></a>

		   					</div>
			
		</div><!-- col-left -->

				<div class="related-posts col-right">
			<h4>Related Posts:</h4>
			<div class="woo-sc-related-posts">
<ul>
<li class="post-id-210006720943855">

<a href="https://www.thestandard.co.zw/2017/05/28/mandiwanzira-rallies-behind-zimdancehall/" title="Mandiwanzira rallies behind Zimdancehall" class="related-title"><span>Mandiwanzira rallies behind Zimdancehall</span></a>
</li>
<li class="post-id-210006720943856">

<a href="https://www.thestandard.co.zw/2017/05/28/mothers-death-brings-fugitive-roki-home/" title="Mother’s death brings ‘fugitive’ Roki home" class="related-title"><span>Mother’s death brings ‘fugitive’ Roki home</span></a>
</li>
<li class="post-id-210006720943892">

<a href="https://www.thestandard.co.zw/2017/05/28/mhere-headline-spiritual-spectacles-night-bulawayo/" title="Mhere to headline Spiritual Spectacles Night in Bulawayo" class="related-title"><span>Mhere to headline Spiritual Spectacles Night in Bulawayo</span></a>
</li>
<li class="post-id-210006720943883">

<a href="https://www.thestandard.co.zw/2017/05/28/diasporans-reach-zim-via-comedy-skits/" title="Diasporans reach out to Zim via comedy skits" class="related-title"><span>Diasporans reach out to Zim via comedy skits</span></a>
</li>
<li class="post-id-210006720943864">

<a href="https://www.thestandard.co.zw/2017/05/28/urban-groover-james-adams-breaks-silence/" title="Urban groover, James Adams breaks silence" class="related-title"><span>Urban groover, James Adams breaks silence</span></a>
</li>
</ul>
<div class="fix"></div><!--/.fix-->
</div><!--/.woo-sc-related-posts-->		</div><!-- col-right -->
		
        <div class="fix"></div>
	</aside>
	<div class="post-utility"></div>
</article><!-- /.post -->
	        <div class="post-entries">
	            <div class="nav-prev fl"><a href="https://www.thestandard.co.zw/2017/05/28/bona-critics-can-go-hell-says-minister/" rel="prev"><i class="icon-angle-left"></i> Bona critics can go to hell, says minister</a></div>
	            <div class="nav-next fr"><a href="https://www.thestandard.co.zw/2017/05/28/mugabe-succession-brawl-turns-bloody/" rel="next">Mugabe succession brawl turns bloody <i class="icon-angle-right"></i></a></div>
	            <div class="fix"></div>
	        </div>

		<!-- MarketGidComposite Start --> <div 
id="MarketGidComposite21864"><center> <a id="mg_add21864" href=" 
" 
target="_blank">Place your ad here</a><br> <a href="" 
target="_blank">Loading...</a> </center></div> <script 
type="text/javascript"> window.MGWidgetTitle21864 = "Promoted Content"; var 
MarketGidDate = new Date(); document.write('<scr'+'ipt 
type="text/javascript" ' +'src="//jsc.mgid.com/t/h/thestandard.co.zw 
.21864.js?t='+MarketGidDate.getYear()+MarketGidDate.getMonth()+MarketGidDate.getDay()+MarketGidDate.getHours() 
<http://jsc.mgid.com/t/h/thestandard.co.zw.21864.js?t=%27+MarketGidDate.getYear()+MarketGidDate.getMonth()+MarketGidDate.getDay()+MarketGidDate.getHours()> 
+ 
'" charset="utf-8" ></scr'+'ipt>'); </script> <!-- MarketGidComposite End 
--><div id="comments">		 	<h3 id="comments-title">2 Responses to <em>Jah Prayzah retraces his roots</em></h3>
		 	<ol class="commentlist">
					                 
		<li class="comment even thread-even depth-1">
	    
	    	<a name="comment-99798"></a>
	      	
	      	<div id="li-comment-99798" class="comment-container">
	      	
					                <div class="avatar"><img alt='' src='https://secure.gravatar.com/avatar/1f60dd47fa51d4d5502196e31eca8312?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1f60dd47fa51d4d5502196e31eca8312?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></div>
	                        
	
		      	<div class="comment-head">
		      	            
	                <span class="name">Tozvireva</span>           
	                <span class="date">May 28, 2017 at 9:42 am</span>
	                <span class="perma"><a href="https://www.thestandard.co.zw/2017/05/28/jah-prayzah-retraces-roots/#comment-99798" title="Direct link to this comment">#</a></span>
	                <span class="edit"></span>
		        		          	
				</div><!-- /.comment-head -->
		      
		   		<div class="comment-entry"  id="comment-99798">
				
				<p>Kudos to you Jah Prayzah</p>
		            
										
	                <div class="reply">
	                    <a rel='nofollow' class='comment-reply-link' href='https://www.thestandard.co.zw/2017/05/28/jah-prayzah-retraces-roots/?replytocom=99798#respond' onclick='return addComment.moveForm( "comment-99798", "99798", "respond", "210006720943863" )' aria-label='Reply to Tozvireva'>Reply</a>	                </div><!-- /.reply -->                       
			
				</div><!-- /comment-entry -->
	
			</div><!-- /.comment-container -->
			
	</li><!-- #comment-## -->
	                 
		<li class="comment odd alt thread-odd thread-alt depth-1">
	    
	    	<a name="comment-99807"></a>
	      	
	      	<div id="li-comment-99807" class="comment-container">
	      	
					                <div class="avatar"><img alt='' src='https://secure.gravatar.com/avatar/78f50068312c85fc32a30133c45f9f97?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/78f50068312c85fc32a30133c45f9f97?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></div>
	                        
	
		      	<div class="comment-head">
		      	            
	                <span class="name">jet li</span>           
	                <span class="date">May 28, 2017 at 1:53 pm</span>
	                <span class="perma"><a href="https://www.thestandard.co.zw/2017/05/28/jah-prayzah-retraces-roots/#comment-99807" title="Direct link to this comment">#</a></span>
	                <span class="edit"></span>
		        		          	
				</div><!-- /.comment-head -->
		      
		   		<div class="comment-entry"  id="comment-99807">
				
				<p>Ndokugona kauku jah haufanire kungoverengwa mu newspaper for wrong reasons</p>
		            
										
	                <div class="reply">
	                    <a rel='nofollow' class='comment-reply-link' href='https://www.thestandard.co.zw/2017/05/28/jah-prayzah-retraces-roots/?replytocom=99807#respond' onclick='return addComment.moveForm( "comment-99807", "99807", "respond", "210006720943863" )' aria-label='Reply to jet li'>Reply</a>	                </div><!-- /.reply -->                       
			
				</div><!-- /comment-entry -->
	
			</div><!-- /.comment-container -->
			
	</li><!-- #comment-## -->
			</ol>
		 	</div>				<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/05/28/jah-prayzah-retraces-roots/#respond" style="display:none;">Click here to cancel reply.</a></small></h3>				<form action="https://www.thestandard.co.zw/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<p class="comment-form-comment"><label class="hide" for="comment">Comment</label> <textarea tabindex="4" id="comment" name="comment" cols="50" rows="10" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" class="txt" tabindex="1" value="" size="30" aria-required='true' /><label for="author">Name <span class="required">(required)</span></label> </p>
<p class="comment-form-email"><input id="email" name="email" type="text" class="txt" tabindex="2" value="" size="30" aria-required='true' /><label for="email">Email (will not be published) <span class="required">(required)</span></label> </p>
<p class="comment-form-url"><input id="url" name="url" type="text" class="txt" tabindex="3" value="" size="30" /><label for="url">Website</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='210006720943863' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>		<p class="antispam-group antispam-group-q" style="clear: both;">
			<label>Current ye@r <span class="required">*</span></label>
			<input type="hidden" name="antspm-a" class="antispam-control antispam-control-a" value="2017" />
			<input type="text" name="antspm-q" class="antispam-control antispam-control-q" value="4.2" autocomplete="off" />
		</p>
		<p class="antispam-group antispam-group-e" style="display: none;">
			<label>Leave this field empty</label>
			<input type="text" name="antspm-e-email-url-website" class="antispam-control antispam-control-e" value="" autocomplete="off" />
		</p>
				</form>
					</div><!-- #respond -->
		     
            </section><!-- /#main -->
                
            <aside id="sidebar">
<div id="text-32" class="widget widget_text">			<div class="textwidget"><script type="text/javascript"><!--
google_ad_client = "ca-pub-3786607324213394";
/* ST_Article */
google_ad_slot = "2074462840";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div>
		</div><div id="woodojo_tabs-3" class="widget widget_woodojo_tabs"><div class="tabbable tabs-above">
<ul class="nav nav-tabs">
<li class="tab-heading-latest first active"><a href="#tab-pane-latest">Latest</a></li>
<li class="tab-heading-popular"><a href="#tab-pane-popular">Popular</a></li>
<li class="tab-heading-comments"><a href="#tab-pane-comments">Comments</a></li>
<li class="tab-heading-tags last"><a href="#tab-pane-tags">Tags</a></li>
</ul>
<div class="tab-content image-align-left">
<div id="tab-pane-latest" class="tab-pane tab-pane-latest first active">
<ul class="latest">
<li>
<a title="Costa Maradzike’s Bindura dream" href="https://www.thestandard.co.zw/2017/05/28/costa-maradzikes-bindura-dream/" ><a href="https://www.thestandard.co.zw/2017/05/28/costa-maradzikes-bindura-dream/"><img width="45" height="30" src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Costa-Maradzike-100x67.jpg" class="woo-image thumbnail wp-post-image" alt="Costa Maradzike" srcset="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Costa-Maradzike-100x67.jpg 100w, https://www.thestandard.co.zw/wp-content/uploads/2017/05/Costa-Maradzike-300x200.jpg 300w, https://www.thestandard.co.zw/wp-content/uploads/2017/05/Costa-Maradzike-200x133.jpg 200w, https://www.thestandard.co.zw/wp-content/uploads/2017/05/Costa-Maradzike.jpg 600w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Costa Maradzike’s Bindura dream" href="https://www.thestandard.co.zw/2017/05/28/costa-maradzikes-bindura-dream/">Costa Maradzike’s Bindura dream</a>
<span class="meta">May 28, 2017</span>
</li>
<li>
<a title="Chinamasa pledge raises eyebrows" href="https://www.thestandard.co.zw/2017/05/28/chinamasa-pledge-raises-eyebrows/" ><a href="https://www.thestandard.co.zw/2017/05/28/chinamasa-pledge-raises-eyebrows/"><img width="45" height="30" src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/the-minister-of-finance-Patrick-Chinamasa-talks-to-the-reserve-bank-governor-John-Mangudya-100x67.gif" class="woo-image thumbnail wp-post-image" alt="The Finance minister Patrick Chinamasa (left) talks to the RBZ governor John Mangudya" srcset="https://www.thestandard.co.zw/wp-content/uploads/2017/05/the-minister-of-finance-Patrick-Chinamasa-talks-to-the-reserve-bank-governor-John-Mangudya-100x67.gif 100w, https://www.thestandard.co.zw/wp-content/uploads/2017/05/the-minister-of-finance-Patrick-Chinamasa-talks-to-the-reserve-bank-governor-John-Mangudya-300x200.gif 300w, https://www.thestandard.co.zw/wp-content/uploads/2017/05/the-minister-of-finance-Patrick-Chinamasa-talks-to-the-reserve-bank-governor-John-Mangudya-200x133.gif 200w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Chinamasa pledge raises eyebrows" href="https://www.thestandard.co.zw/2017/05/28/chinamasa-pledge-raises-eyebrows/">Chinamasa pledge raises eyebrows</a>
<span class="meta">May 28, 2017</span>
</li>
<li>
<a title="Juju tales resurrect ex-DeMbare star" href="https://www.thestandard.co.zw/2017/05/28/juju-tales-resurrect-ex-dembare-star/" ><a href="https://www.thestandard.co.zw/2017/05/28/juju-tales-resurrect-ex-dembare-star/"><img width="45" height="30" src="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Memory-Mucherahowa-100x67.gif" class="woo-image thumbnail wp-post-image" alt="Memory Mucherahowa (centre) signs a copy of his book, Soul of Seven Million Dreams for a fans during last week&#039;s official book launch in London" srcset="https://www.thestandard.co.zw/wp-content/uploads/2017/05/Memory-Mucherahowa-100x67.gif 100w, https://www.thestandard.co.zw/wp-content/uploads/2017/05/Memory-Mucherahowa-300x200.gif 300w, https://www.thestandard.co.zw/wp-content/uploads/2017/05/Memory-Mucherahowa-200x133.gif 200w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Juju tales resurrect ex-DeMbare star" href="https://www.thestandard.co.zw/2017/05/28/juju-tales-resurrect-ex-dembare-star/">Juju tales resurrect ex-DeMbare star</a>
<span class="meta">May 28, 2017</span>
</li>
<li>
<a title="Mugabe nephew strikes again" href="https://www.thestandard.co.zw/2017/05/28/mugabe-nephew-strikes/" ><a href="https://www.thestandard.co.zw/2017/05/28/mugabe-nephew-strikes/"><img width="45" height="30" src="https://www.thestandard.co.zw/wp-content/uploads/2016/09/bob-100x67.gif" class="woo-image thumbnail wp-post-image" alt="President Robert Mugabe" srcset="https://www.thestandard.co.zw/wp-content/uploads/2016/09/bob-100x67.gif 100w, https://www.thestandard.co.zw/wp-content/uploads/2016/09/bob-300x200.gif 300w, https://www.thestandard.co.zw/wp-content/uploads/2016/09/bob-200x133.gif 200w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Mugabe nephew strikes again" href="https://www.thestandard.co.zw/2017/05/28/mugabe-nephew-strikes/">Mugabe nephew strikes again</a>
<span class="meta">May 28, 2017</span>
</li>
<li>
<a title="Ministers, top officials face arrest" href="https://www.thestandard.co.zw/2017/05/28/ministers-top-officials-face-arrest/" ><a href="https://www.thestandard.co.zw/2017/05/28/ministers-top-officials-face-arrest/"><img width="45" height="36" src="https://www.thestandard.co.zw/wp-content/uploads/2013/09/Jacob-Mudenda-100x80.jpg" class="woo-image thumbnail wp-post-image" alt="Jacob-Mudenda" srcset="https://www.thestandard.co.zw/wp-content/uploads/2013/09/Jacob-Mudenda-100x80.jpg 100w, https://www.thestandard.co.zw/wp-content/uploads/2013/09/Jacob-Mudenda-200x160.jpg 200w, https://www.thestandard.co.zw/wp-content/uploads/2013/09/Jacob-Mudenda.jpg 300w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Ministers, top officials face arrest" href="https://www.thestandard.co.zw/2017/05/28/ministers-top-officials-face-arrest/">Ministers, top officials face arrest</a>
<span class="meta">May 28, 2017</span>
</li>
</ul>
</div><!--/.tab-pane-->
<div id="tab-pane-popular" class="tab-pane tab-pane-popular">
<ul class="popular">
<li>
<a title="Makandiwa  breathes fire" href="https://www.thestandard.co.zw/2015/11/01/makandiwa-breathes-fire/" ><a href="https://www.thestandard.co.zw/2015/11/01/makandiwa-breathes-fire/"><img width="45" height="13" src="https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa-200x59.jpg" class="woo-image thumbnail wp-post-image" alt="emmanuel-makandiwa" srcset="https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa-200x59.jpg 200w, https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa-300x89.jpg 300w, https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa-100x30.jpg 100w, https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa.jpg 674w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Makandiwa  breathes fire" href="https://www.thestandard.co.zw/2015/11/01/makandiwa-breathes-fire/">Makandiwa  breathes fire</a>
<span class="meta">November 1, 2015</span>
</li>
<li>
<a title="Makandiwa blasts false prophets" href="https://www.thestandard.co.zw/2015/10/11/makandiwa-blasts-false-prophets/" ><a href="https://www.thestandard.co.zw/2015/10/11/makandiwa-blasts-false-prophets/"><img width="45" height="13" src="https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa-200x59.jpg" class="woo-image thumbnail wp-post-image" alt="emmanuel-makandiwa" srcset="https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa-200x59.jpg 200w, https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa-300x89.jpg 300w, https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa-100x30.jpg 100w, https://www.thestandard.co.zw/wp-content/uploads/2015/10/emmanuel-makandiwa.jpg 674w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Makandiwa blasts false prophets" href="https://www.thestandard.co.zw/2015/10/11/makandiwa-blasts-false-prophets/">Makandiwa blasts false prophets</a>
<span class="meta">October 11, 2015</span>
</li>
<li>
<a title="Extra-marital affair saga: Magaya fights back" href="https://www.thestandard.co.zw/2016/05/29/magaya-fights-back/" ><a href="https://www.thestandard.co.zw/2016/05/29/magaya-fights-back/"><img width="45" height="30" src="https://www.thestandard.co.zw/wp-content/uploads/2015/11/magaya-100x67.jpg" class="woo-image thumbnail wp-post-image" alt="magaya" srcset="https://www.thestandard.co.zw/wp-content/uploads/2015/11/magaya-100x67.jpg 100w, https://www.thestandard.co.zw/wp-content/uploads/2015/11/magaya-300x200.jpg 300w, https://www.thestandard.co.zw/wp-content/uploads/2015/11/magaya-200x133.jpg 200w, https://www.thestandard.co.zw/wp-content/uploads/2015/11/magaya.jpg 600w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Extra-marital affair saga: Magaya fights back" href="https://www.thestandard.co.zw/2016/05/29/magaya-fights-back/">Extra-marital affair saga: Magaya fights back</a>
<span class="meta">May 29, 2016</span>
</li>
<li>
<a title="Mugabe outwits PM Tsvangirai again" href="https://www.thestandard.co.zw/2013/01/20/mugabe-outwits-pm-tsvangirai-again/" ><a href="https://www.thestandard.co.zw/2013/01/20/mugabe-outwits-pm-tsvangirai-again/"><img width="45" height="30" src="https://www.thestandard.co.zw/wp-content/uploads/2012/11/robert-mugabe-5-100x66.jpg" class="woo-image thumbnail wp-post-image" alt="robert-mugabe-5" srcset="https://www.thestandard.co.zw/wp-content/uploads/2012/11/robert-mugabe-5-100x66.jpg 100w, https://www.thestandard.co.zw/wp-content/uploads/2012/11/robert-mugabe-5-300x200.jpg 300w, https://www.thestandard.co.zw/wp-content/uploads/2012/11/robert-mugabe-5-200x133.jpg 200w, https://www.thestandard.co.zw/wp-content/uploads/2012/11/robert-mugabe-5.jpg 450w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Mugabe outwits PM Tsvangirai again" href="https://www.thestandard.co.zw/2013/01/20/mugabe-outwits-pm-tsvangirai-again/">Mugabe outwits PM Tsvangirai again</a>
<span class="meta">January 20, 2013</span>
</li>
<li>
<a title="Sadc leaders humiliate Mugabe" href="https://www.thestandard.co.zw/2013/06/16/sadc-leaders-humiliate-mugabe/" ><a href="https://www.thestandard.co.zw/2013/06/16/sadc-leaders-humiliate-mugabe/"><img width="45" height="30" src="https://www.thestandard.co.zw/wp-content/uploads/2012/10/Chinamasa-std-100x66.jpg" class="woo-image thumbnail wp-post-image" alt="Chinamasa-std" srcset="https://www.thestandard.co.zw/wp-content/uploads/2012/10/Chinamasa-std-100x66.jpg 100w, https://www.thestandard.co.zw/wp-content/uploads/2012/10/Chinamasa-std-200x133.jpg 200w, https://www.thestandard.co.zw/wp-content/uploads/2012/10/Chinamasa-std.jpg 300w" sizes="(max-width: 45px) 100vw, 45px" /></a></a><a title="Sadc leaders humiliate Mugabe" href="https://www.thestandard.co.zw/2013/06/16/sadc-leaders-humiliate-mugabe/">Sadc leaders humiliate Mugabe</a>
<span class="meta">June 16, 2013</span>
</li>
</ul>
</div><!--/.tab-pane-->
<div id="tab-pane-comments" class="tab-pane tab-pane-comments">
<ul class="comments">
<li>
<img alt='' src='https://secure.gravatar.com/avatar/3804ecc606de94dfc671d1ec903847fa?s=45&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/3804ecc606de94dfc671d1ec903847fa?s=90&amp;d=mm&amp;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /><a title="raf maguu on Mugabe nephew strikes again" href="https://www.thestandard.co.zw/2017/05/28/mugabe-nephew-strikes/#comment-99821">raf maguu</a>
<span class="comment-content">why on earth does what zhuwawo says matter?</span>
</li>
<li>
<img alt='' src='https://secure.gravatar.com/avatar/f4fc6d200c0f6c3ab6a3f0f32524674a?s=45&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f4fc6d200c0f6c3ab6a3f0f32524674a?s=90&amp;d=mm&amp;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /><a title="Nyakasikana on Chidyausiku’s most profound words" href="https://www.thestandard.co.zw/2017/05/28/chidyausikus-profound-words/#comment-99818">Nyakasikana</a>
<span class="comment-content">I never got to meet this son of the soil, but i ho</span>
</li>
<li>
<img alt='' src='https://secure.gravatar.com/avatar/2366f669bf4207ff722dc1b39edfe1c9?s=45&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/2366f669bf4207ff722dc1b39edfe1c9?s=90&amp;d=mm&amp;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /><a title="suzi on Mugabe spends a staggering 77 days out of Zim in 2017" href="https://www.thestandard.co.zw/2017/05/28/mugabe-spends-staggering-77-days-zim-2017/#comment-99817">suzi</a>
<span class="comment-content">we can only hope the next time he gets on the plan</span>
</li>
<li>
<img alt='' src='https://secure.gravatar.com/avatar/ccdb47635a7c8c96e89390bd0073acb8?s=45&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ccdb47635a7c8c96e89390bd0073acb8?s=90&amp;d=mm&amp;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /><a title="Mapalo on Robert Mugabe’s  nepotism stinks" href="https://www.thestandard.co.zw/2017/05/28/robert-mugabes-nepotism-stinks/#comment-99816">Mapalo</a>
<span class="comment-content">change is inevitable...</span>
</li>
<li>
<img alt='' src='https://secure.gravatar.com/avatar/a7f7263daa6d1fa4aa1928dd9a214a70?s=45&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a7f7263daa6d1fa4aa1928dd9a214a70?s=90&amp;d=mm&amp;r=g 2x' class='avatar avatar-45 photo' height='45' width='45' /><a title="Tawanda Mpambwa on Mugabe nephew strikes again" href="https://www.thestandard.co.zw/2017/05/28/mugabe-nephew-strikes/#comment-99813">Tawanda Mpambwa</a>
<span class="comment-content">I think Rasta is off side on this one, since every</span>
</li>
</ul>
</div><!--/.tab-pane-->
<div id="tab-pane-tags" class="tab-pane tab-pane-tags last">
<a href='https://www.thestandard.co.zw/tag/asiagate/' class='tag-link-23877 tag-link-position-1' title='15 topics' style='font-size: 12.140350877193pt;'>Asiagate</a>
<a href='https://www.thestandard.co.zw/tag/black-rhinos/' class='tag-link-24167 tag-link-position-2' title='15 topics' style='font-size: 12.140350877193pt;'>Black Rhinos</a>
<a href='https://www.thestandard.co.zw/tag/bulawayo/' class='tag-link-23541 tag-link-position-3' title='33 topics' style='font-size: 14.456140350877pt;'>bulawayo</a>
<a href='https://www.thestandard.co.zw/tag/caps-united/' class='tag-link-23544 tag-link-position-4' title='28 topics' style='font-size: 13.964912280702pt;'>caps united</a>
<a href='https://www.thestandard.co.zw/tag/castle-lager-premier-soccer-league/' class='tag-link-24229 tag-link-position-5' title='16 topics' style='font-size: 12.350877192982pt;'>Castle Lager Premier Soccer League</a>
<a href='https://www.thestandard.co.zw/tag/chicken-inn/' class='tag-link-23672 tag-link-position-6' title='19 topics' style='font-size: 12.842105263158pt;'>Chicken Inn</a>
<a href='https://www.thestandard.co.zw/tag/china/' class='tag-link-23626 tag-link-position-7' title='19 topics' style='font-size: 12.842105263158pt;'>china</a>
<a href='https://www.thestandard.co.zw/tag/cricket/' class='tag-link-23719 tag-link-position-8' title='21 topics' style='font-size: 13.122807017544pt;'>cricket</a>
<a href='https://www.thestandard.co.zw/tag/cuthbert-dube/' class='tag-link-23961 tag-link-position-9' title='17 topics' style='font-size: 12.561403508772pt;'>cuthbert dube</a>
<a href='https://www.thestandard.co.zw/tag/didymus-mutasa/' class='tag-link-24920 tag-link-position-10' title='14 topics' style='font-size: 12pt;'>Didymus Mutasa</a>
<a href='https://www.thestandard.co.zw/tag/dynamos/' class='tag-link-23543 tag-link-position-11' title='64 topics' style='font-size: 16.421052631579pt;'>Dynamos</a>
<a href='https://www.thestandard.co.zw/tag/economy/' class='tag-link-24302 tag-link-position-12' title='23 topics' style='font-size: 13.40350877193pt;'>economy</a>
<a href='https://www.thestandard.co.zw/tag/elections/' class='tag-link-23748 tag-link-position-13' title='51 topics' style='font-size: 15.789473684211pt;'>elections</a>
<a href='https://www.thestandard.co.zw/tag/fc-platinum/' class='tag-link-23670 tag-link-position-14' title='37 topics' style='font-size: 14.80701754386pt;'>FC Platinum</a>
<a href='https://www.thestandard.co.zw/tag/grace-mugabe/' class='tag-link-23511 tag-link-position-15' title='19 topics' style='font-size: 12.842105263158pt;'>Grace Mugabe</a>
<a href='https://www.thestandard.co.zw/tag/harare/' class='tag-link-23581 tag-link-position-16' title='32 topics' style='font-size: 14.385964912281pt;'>harare</a>
<a href='https://www.thestandard.co.zw/tag/health-and-fitness/' class='tag-link-23866 tag-link-position-17' title='14 topics' style='font-size: 12pt;'>Health and fitness</a>
<a href='https://www.thestandard.co.zw/tag/highlanders/' class='tag-link-23667 tag-link-position-18' title='37 topics' style='font-size: 14.80701754386pt;'>Highlanders</a>
<a href='https://www.thestandard.co.zw/tag/how-mine/' class='tag-link-24615 tag-link-position-19' title='16 topics' style='font-size: 12.350877192982pt;'>How Mine</a>
<a href='https://www.thestandard.co.zw/tag/ian-gorowa/' class='tag-link-26789 tag-link-position-20' title='19 topics' style='font-size: 12.842105263158pt;'>Ian Gorowa</a>
<a href='https://www.thestandard.co.zw/tag/joice-mujuru/' class='tag-link-24020 tag-link-position-21' title='19 topics' style='font-size: 12.842105263158pt;'>Joice Mujuru</a>
<a href='https://www.thestandard.co.zw/tag/masvingo/' class='tag-link-23807 tag-link-position-22' title='14 topics' style='font-size: 12pt;'>Masvingo</a>
<a href='https://www.thestandard.co.zw/tag/mdc/' class='tag-link-23750 tag-link-position-23' title='31 topics' style='font-size: 14.315789473684pt;'>mdc</a>
<a href='https://www.thestandard.co.zw/tag/mdc-t/' class='tag-link-23583 tag-link-position-24' title='69 topics' style='font-size: 16.701754385965pt;'>MDC-T</a>
<a href='https://www.thestandard.co.zw/tag/morgan-tsvangirai/' class='tag-link-23851 tag-link-position-25' title='54 topics' style='font-size: 15.929824561404pt;'>morgan Tsvangirai</a>
<a href='https://www.thestandard.co.zw/tag/mugabe/' class='tag-link-23636 tag-link-position-26' title='18 topics' style='font-size: 12.701754385965pt;'>mugabe</a>
<a href='https://www.thestandard.co.zw/tag/music/' class='tag-link-23699 tag-link-position-27' title='19 topics' style='font-size: 12.842105263158pt;'>music</a>
<a href='https://www.thestandard.co.zw/tag/mutare/' class='tag-link-23538 tag-link-position-28' title='25 topics' style='font-size: 13.614035087719pt;'>mutare</a>
<a href='https://www.thestandard.co.zw/tag/rbz/' class='tag-link-23642 tag-link-position-29' title='15 topics' style='font-size: 12.140350877193pt;'>RBZ</a>
<a href='https://www.thestandard.co.zw/tag/robert-mugabe/' class='tag-link-23585 tag-link-position-30' title='84 topics' style='font-size: 17.263157894737pt;'>Robert Mugabe</a>
<a href='https://www.thestandard.co.zw/tag/rugby/' class='tag-link-23509 tag-link-position-31' title='15 topics' style='font-size: 12.140350877193pt;'>rugby</a>
<a href='https://www.thestandard.co.zw/tag/slider/' class='tag-link-23505 tag-link-position-32' title='35 topics' style='font-size: 14.666666666667pt;'>slider</a>
<a href='https://www.thestandard.co.zw/tag/soccer/' class='tag-link-23514 tag-link-position-33' title='40 topics' style='font-size: 15.017543859649pt;'>Soccer</a>
<a href='https://www.thestandard.co.zw/tag/south-africa/' class='tag-link-23624 tag-link-position-34' title='25 topics' style='font-size: 13.614035087719pt;'>south africa</a>
<a href='https://www.thestandard.co.zw/tag/tendai-biti/' class='tag-link-23617 tag-link-position-35' title='23 topics' style='font-size: 13.40350877193pt;'>tendai biti</a>
<a href='https://www.thestandard.co.zw/tag/tennis/' class='tag-link-23661 tag-link-position-36' title='20 topics' style='font-size: 12.982456140351pt;'>Tennis</a>
<a href='https://www.thestandard.co.zw/tag/tourism/' class='tag-link-23578 tag-link-position-37' title='15 topics' style='font-size: 12.140350877193pt;'>tourism</a>
<a href='https://www.thestandard.co.zw/tag/unwto/' class='tag-link-23577 tag-link-position-38' title='14 topics' style='font-size: 12pt;'>unwto</a>
<a href='https://www.thestandard.co.zw/tag/warriors/' class='tag-link-23536 tag-link-position-39' title='44 topics' style='font-size: 15.298245614035pt;'>Warriors</a>
<a href='https://www.thestandard.co.zw/tag/water/' class='tag-link-24593 tag-link-position-40' title='14 topics' style='font-size: 12pt;'>water</a>
<a href='https://www.thestandard.co.zw/tag/zanu-pf/' class='tag-link-23586 tag-link-position-41' title='133 topics' style='font-size: 18.666666666667pt;'>Zanu PF</a>
<a href='https://www.thestandard.co.zw/tag/zifa/' class='tag-link-23520 tag-link-position-42' title='62 topics' style='font-size: 16.350877192982pt;'>Zifa</a>
<a href='https://www.thestandard.co.zw/tag/zimbabwe/' class='tag-link-23523 tag-link-position-43' title='208 topics' style='font-size: 20pt;'>zimbabwe</a>
<a href='https://www.thestandard.co.zw/tag/zimbabwe-soccer/' class='tag-link-23518 tag-link-position-44' title='47 topics' style='font-size: 15.508771929825pt;'>Zimbabwe Soccer</a>
<a href='https://www.thestandard.co.zw/tag/zpc-kariba/' class='tag-link-24169 tag-link-position-45' title='19 topics' style='font-size: 12.842105263158pt;'>ZPC Kariba</a></div><!--/.tab-pane-->
</div><!--/.tab-content-->
</div><!--/.tabbable-->
</div><div id="text-34" class="widget widget_text">			<div class="textwidget"><script type="text/javascript"><!--
google_ad_client = "ca-pub-3786607324213394";
/* ST_Article */
google_ad_slot = "2074462840";
google_ad_width = 300;
google_ad_height = 600;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div>
		</div></aside><!-- /#sidebar -->

		</div><!-- /#main-sidebar-container -->         

		
    </div><!-- /#content -->
	
<!-- Either there are no banners, they are disabled or none qualified for this location! -->	<div class="subscribe-call">
		<a href="https://www.thestandard.co.zw/subscribe/"><img src="https://www.thestandard.co.zw/wp-content/uploads/2016/09/std-footer-logo.png" alt="logo" width="300"/></a>
		<a class="subscribe-text" href="https://www.thestandard.co.zw/subscribe/">Subscribe to The Standard now</a>
		<a class="button" href="https://www.thestandard.co.zw/subscribe/">Subscribe</a>
		<div class="fix"></div>
	</div>
	<div class="footer-nav-container">
		<div class="footer-nav">
			<p>Legal:</p>
			<div class="menu"><ul id="menu-legal-menu" class="nav"><li id="menu-item-56557" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56557"><a href="https://www.thestandard.co.zw/copyright/">Copyright</a></li>
<li id="menu-item-53577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53577"><a href="https://www.thestandard.co.zw/disclaimer/">Disclaimer</a></li>
<li id="menu-item-53578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53578"><a href="https://www.thestandard.co.zw/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-53579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53579"><a href="https://www.thestandard.co.zw/terms-and-conditions/">Terms and Conditions</a></li>
</ul></div>			<div class="fix"></div>	
		</div>
		<div class="footer-nav">
			<p>Our Partners:</p>
			<div class="menu"><ul id="menu-partner-sites" class="nav"><li id="menu-item-54709" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54709"><a href="http://theindependent.co.zw/">Zimbabwe Independent</a></li>
<li id="menu-item-54710" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54710"><a href="http://newsday.co.zw/">NewsDay</a></li>
<li id="menu-item-210006720922598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-210006720922598"><a href="http://www.southerneye.co.zw/">Southern Eye</a></li>
<li id="menu-item-54711" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54711"><a href="http://mg.co.za/">Mail &#038; Guardian</a></li>
<li id="menu-item-210006720933881" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-210006720933881"><a href="http://www.myclassifieds.co.zw">MyClassifieds</a></li>
</ul></div>			<div class="fix"></div>	
		</div>
		<div class="footer-nav">
			<p>Categories:</p>
			<div class="menu"><ul id="menu-footer-categories" class="nav"><li id="menu-item-54712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54712"><a href="https://www.thestandard.co.zw/local-zimbabwe-stories/">Local</a></li>
<li id="menu-item-54716" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54716"><a href="https://www.thestandard.co.zw/opinion/">Opinion</a></li>
<li id="menu-item-54717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54717"><a href="https://www.thestandard.co.zw/editorial/">Editorial</a></li>
<li id="menu-item-54719" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54719"><a href="https://www.thestandard.co.zw/international/">International</a></li>
<li id="menu-item-54714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54714"><a href="https://www.thestandard.co.zw/letters/">Letters</a></li>
<li id="menu-item-54720" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54720"><a href="https://www.thestandard.co.zw/cartoons/">Cartoons</a></li>
<li id="menu-item-210006720928162" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210006720928162"><a href="https://www.thestandard.co.zw/queenmakers/">QueenMakers</a></li>
</ul></div>			<div class="fix"></div>	
		</div>
		<div class="footer-nav last">
			<p>The Standard:</p>
			<div class="menu"><ul id="menu-the-standard" class="nav"><li id="menu-item-54721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54721"><a href="https://www.thestandard.co.zw/about-us/">About us</a></li>
<li id="menu-item-54723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54723"><a href="https://www.thestandard.co.zw/contact-us/">Contact us</a></li>
<li id="menu-item-54724" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54724"><a href="https://www.thestandard.co.zw/subscribe/">Subscribe</a></li>
<li id="menu-item-54722" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54722"><a href="https://www.thestandard.co.zw/advertise/">Advertise</a></li>
</ul></div>			<div class="fix"></div>	
		</div> 
	</div>
		<footer id="footer" class="col-full">

		
		<div class="col-left">
			<p><img src="/wp-content/uploads/2016/06/amh-logo-smal-1.jpg" alt="AMH logo" /></p>		</div>
		
		<div class="col-mid">
			<p>© 2017 The Zimind. All Rights reserved.</p>
		</div>
		
		<div class="col-right">
			<p><img src="/wp-content/uploads/2012/05/dmma-logo.jpg" alt="DMMA logo" /></p>		</div>

	</footer>

	
	</div><!-- /#inner-wrapper -->

</div><!-- /#wrapper -->

<div class="fix"></div><!--/.fix-->

<img src="" id="fsb_image"/><!--script type="text/javascript"> 
window._taboola = window._taboola || []; 
_taboola.push({flush: true}); 
</script--!>

	<script type='text/javascript' src='https://www.thestandard.co.zw/wp-includes/js/comment-reply.min.js?ver=4.5.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/www.thestandard.co.zw\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.thestandard.co.zw\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-content/plugins/anti-spam/js/anti-spam-4.2.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var qpprFrontData = {"linkData":[],"siteURL":"https:\/\/www.thestandard.co.zw","siteURLq":"https:\/\/www.thestandard.co.zw"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.1.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPUSBVars = {"ajaxUrl":"https:\/\/www.thestandard.co.zw\/wp-admin\/admin-ajax.php","context":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-content/plugins/wpupper-share-buttons/assets/javascripts/front/built.js?ver=3.12'></script>
<script type='text/javascript' src='https://www.thestandard.co.zw/wp-includes/js/wp-embed.min.js?ver=4.5.9'></script>
			<div class="wpusb-modal-mask"
			     data-wpusb-component="social-modal"
			     style="display:none;">

				<a class="wpusb-btn-close" data-action="close-popup">
					<i class="wpusb-icon-close"></i>
				</a>
			</div>
			<div class="wpusb-modal-networks">				<div class="wpusb-element-popup">
					<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
					   class="wpusb-button-popup wpusb-facebook-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Facebook"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-facebook wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Facebook"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="https://twitter.com/share?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&text=I just saw%20Jah%20Prayzah%20retraces%20his%20roots%20-%20Click to see also%20☛%20" target="_blank"
					   class="wpusb-button-popup wpusb-twitter-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Tweet"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-twitter wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Twitter"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&title=Jah%20Prayzah%20retraces%20his%20roots" target="_blank"
					   class="wpusb-button-popup wpusb-linkedin-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Linkedin"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-linkedin wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Linkedin"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
					   class="wpusb-button-popup wpusb-google-plus-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Google+"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-google-plus wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Google Plus"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&media=https%3A%2F%2Fwww.thestandard.co.zw%2Fwp-content%2Fuploads%2F2017%2F05%2FJah-Prayzah-1.gif&description=Jah%20Prayzah%20retraces%20his%20roots" target="_blank"
					   class="wpusb-button-popup wpusb-pinterest-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Pinterest"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-pinterest wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Pinterest"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="http://www.tumblr.com/share" target="_blank"
					   class="wpusb-button-popup wpusb-tumblr-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Tumblr"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-tumblr wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Tumblr"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="whatsapp://send?text=Jah%20Prayzah%20retraces%20his%20roots%20☛%20https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
					   class="wpusb-button-popup wpusb-whatsapp-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on WhatsApp"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-whatsapp wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="WhatsApp"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="mailto:?subject=Jah%20Prayzah%20retraces%20his%20roots&body=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F
%0A%0AJah%20Prayzah%20retraces%20his%20roots%0A%0ATHE%20Biblical%20saying%20that%20%E2%80%9Cblessed%20is%20the%20hand%20that%20giveth%E2%80%9D%20aptly%20describes%20Uzumba-bred%20musician%20Jah%20Prayzah%E2%80%99s%20strong%20sense%20of%20social%20obligation%20and%20charity%20as%20he%20believes%20that%20it%20is%20always%20better%20to%20give%20than%20to%20receive.%0D%0A%0D%0ABY%20WINSTONE%20ANTONIO%0D%0A%0D%0A%0D%0A%0D%0AThe%20highflying%20dreadlocked%20singer%20last%20week%20proved%20that%20society%20deserves%20more%20from%20him%20than%20his%20music.%0D%0A%0D%0AIn%20a%20true%20reflection%20of%20that%2C%20there%20was%20pomp%20and%20funfair%20last%20Saturday%20at%20Musanhi%20Secondary%20School%20in%20Uzumbain%20Mashonaland%20East%20as%20Jah%20Prayzah%20brought%20smiles%20to%20pupils%20at%20his%20former%20school%20and%20surrounding%20areas%20when%20he%20launched%20the%20Tadzoka%20Kumusha%20Soccer%20tournament.%0D%0A%0D%0A%0D%0A%0D%0AFor%20such%20a%20day%2C%20the%20singer%20could%20have%20pocketed%20a%20decent%20package%20for%20a%20performance%2C%20but%20instead%2C%20he%20dedicated%20time%20to%20be%20in%20his%20rural%20area%20for%20a%20social%20responsibility%20gesture.%0D%0A%0D%0AIt%20is%20not%20Jah%20Prayzah%E2%80%99s%20launch%20of%20the%20tournament%20that%20will%20go%20a%20long%20way%20in%20the%20school%E2%80%99s%20history%2C%20but%20also%20his%20pledge%20to%20build%20a%20computer%20laboratory%20that%20would%20cost%20%2430%20000.%0D%0A%0D%0A%E2%80%9CThis%20is%20just%20my%20way%20to%20give%20back%20to%20the%20school%20that%20contributed%20a%20lot%20to%20who%20I%20am%20today%2C%E2%80%9D%20Jah%20Prayzah%20said.%20%0D%0A%0D%0A%0D%0A%0D%0A%E2%80%9CI%20know%20that%20there%20are%20lot%20of%20other%20things%20that%20are%20needed%20by%20the%20school%2C%20but%20I%20decided%20to%20start%20with%20this%20project%20set%20to%20start%20early%20June.%20God%20permitting%2C%20we%20can%20develop%20other%20areas%20in%20the%20future.%E2%80%9D%20%0D%0A%0D%0AIt%20was%20an%20electric%20atmosphere%20at%20the%20tournament%20that%20was%20held%20on%20a%20knock-out%20format%20and%20featured%20four%20teams%20%E2%80%94%20%20Mugabe%20Secondary%20School%2C%20Rudairo%20Secondary%20School%2C%20Nyamhara%20Secondary%20School%20and%20the%20host%20Musanhi%20Secondary%2C%20who%20were%20later%20crowned%20the%20champions.%0D%0A%0D%0AThe%20event%20was%20attended%20by%20Member%20of%20Parliament%20for%20Uzumba%2C%20Simbaneuta%20Mudarikwa%2C%20traditional%20chiefs%2C%20civic%20leaders%20and%20veteran%20sports%20commentator%20Charles%20Mabika%2C%20who%20did%20the%20commentary%20of%20the%20final%20match%20of%20the%20tournament.%0D%0A%0D%0AIn%20an%20interview%20on%20the%20sidelines%20of%20the%20event%2C%20the%20Mdhara%20Vachauya%20hitmaker%20said%20more%20projects%20under%20the%20Tadzoka%20Kumusha%20initiative%20were%20in%20the%20pipeline%20%20as%20he%20endeavours%20to%20make%20a%20better%20tomorrow%20for%20everyone%20in%20his%20rural%20community%20and%20Africa%20at%20large.%0D%0A%0D%0A%0D%0A%0D%0ACommunity%20and%20traditional%20leaders%20hailed%20Jah%20Prayzah%20for%20the%20gesture%2C%20saying%20the%20musician%20was%20a%20true%20role%20model%20in%20Uzumba.%0D%0A%0D%0AJah%20Prayzah%20said%20it%20was%20a%20dream%20come%20true%20to%20host%20the%20tournament%20after%20months%20of%20planning.%0D%0A%0D%0A%E2%80%9CGiving%20back%20to%20a%20community%20and%20the%20people%20who%20paved%20the%20way%20for%20you%20is%20always%20a%20joy.%20I%20am%20really%20honoured%20to%20host%20the%20first%20of%20many%20Jah%20Prayzah%20soccer%20tournaments%20for%20schools%20here.%20I%20have%20always%20dreamt%20of%20the%20day%20I%20would%20get%20to%20spend%20time%20with%20the%20kids.%20It%20is%20my%20hope%20and%20wish%20that%20one%20or%20two%20of%20them%20will%20be%20inspired%20to%20take%20this%20initiative%20further%20when%20they%20grow%20up%2C%E2%80%9D%20he%20said.%0D%0A%0D%0A%E2%80%9CThe%20smiles%20on%20the%20kids%E2%80%99%20faces%20will%20definitely%20push%20for%20more%20works%20and%20projects%20from%20us%20for%20them.%20Like%20the%20saying%20goes%2C%20%E2%80%98honour%20your%20father%20and%20mother%20so%20that%20your%20days%20on%20earth%20may%20be%20increased%E2%80%99.%20For%20us%2C%20it%20is%20not%20only%20limited%20to%20your%20parents%2C%20but%20basically%20where%20you%20come%20from%20and%20just%20remembering%20your%20roots.%E2%80%9D%0D%0A%0D%0A%0D%0A%0D%0AMudarikwa%20saluted%20Jah%20Prayzah%20and%20urged%20the%20pupils%20to%20emulate%20what%20the%20dreadlocked%20musician%20did%20for%20the%20community.%0D%0A%0D%0A%E2%80%9CJah%20Prayzah%20is%20a%20product%20of%20this%20school%20and%20I%20want%20to%20thank%20him%20for%20such%20an%20initiative%20as%20he%20has%20remembered%20the%20importance%20of%20his%20former%20school%20at%20a%20time%20when%20many%20of%20the%20former%20students%20have%20not%20returned%20back%2C%E2%80%9D%20he%20said.%0D%0A%0D%0AHe%20challenged%20pupils%20to%20take%20sports%20seriously%20and%20desist%20from%20taking%20drugs%2C%20which%20he%20said%20destroys%20their%20future.%0A" target="_blank"
					   class="wpusb-button-popup wpusb-email-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Send by email"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-email wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Email"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="http://www.printfriendly.com/print?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
					   class="wpusb-button-popup wpusb-printer-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Print via PrintFriendly"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-printer wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="PrintFriendly"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="https://mail.google.com/mail/u/0/?view=cm&fs=1&su=Jah%20Prayzah%20retraces%20his%20roots&body=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F
%0A%0AJah%20Prayzah%20retraces%20his%20roots%0A%0ATHE%20Biblical%20saying%20that%20%E2%80%9Cblessed%20is%20the%20hand%20that%20giveth%E2%80%9D%20aptly%20describes%20Uzumba-bred%20musician%20Jah%20Prayzah%E2%80%99s%20strong%20sense%20of%20social%20obligation%20and%20charity%20as%20he%20believes%20that%20it%20is%20always%20better%20to%20give%20than%20to%20receive.%0D%0A%0D%0ABY%20WINSTONE%20ANTONIO%0D%0A%0D%0A%0D%0A%0D%0AThe%20highflying%20dreadlocked%20singer%20last%20week%20proved%20that%20society%20deserves%20more%20from%20him%20than%20his%20music.%0D%0A%0D%0AIn%20a%20true%20reflection%20of%20that%2C%20there%20was%20pomp%20and%20funfair%20last%20Saturday%20at%20Musanhi%20Secondary%20School%20in%20Uzumbain%20Mashonaland%20East%20as%20Jah%20Prayzah%20brought%20smiles%20to%20pupils%20at%20his%20former%20school%20and%20surrounding%20areas%20when%20he%20launched%20the%20Tadzoka%20Kumusha%20Soccer%20tournament.%0D%0A%0D%0A%0D%0A%0D%0AFor%20such%20a%20day%2C%20the%20singer%20could%20have%20pocketed%20a%20decent%20package%20for%20a%20performance%2C%20but%20instead%2C%20he%20dedicated%20time%20to%20be%20in%20his%20rural%20area%20for%20a%20social%20responsibility%20gesture.%0D%0A%0D%0AIt%20is%20not%20Jah%20Prayzah%E2%80%99s%20launch%20of%20the%20tournament%20that%20will%20go%20a%20long%20way%20in%20the%20school%E2%80%99s%20history%2C%20but%20also%20his%20pledge%20to%20build%20a%20computer%20laboratory%20that%20would%20cost%20%2430%20000.%0D%0A%0D%0A%E2%80%9CThis%20is%20just%20my%20way%20to%20give%20back%20to%20the%20school%20that%20contributed%20a%20lot%20to%20who%20I%20am%20today%2C%E2%80%9D%20Jah%20Prayzah%20said.%20%0D%0A%0D%0A%0D%0A%0D%0A%E2%80%9CI%20know%20that%20there%20are%20lot%20of%20other%20things%20that%20are%20needed%20by%20the%20school%2C%20but%20I%20decided%20to%20start%20with%20this%20project%20set%20to%20start%20early%20June.%20God%20permitting%2C%20we%20can%20develop%20other%20areas%20in%20the%20future.%E2%80%9D%20%0D%0A%0D%0AIt%20was%20an%20electric%20atmosphere%20at%20the%20tournament%20that%20was%20held%20on%20a%20knock-out%20format%20and%20featured%20four%20teams%20%E2%80%94%20%20Mugabe%20Secondary%20School%2C%20Rudairo%20Secondary%20School%2C%20Nyamhara%20Secondary%20School%20and%20the%20host%20Musanhi%20Secondary%2C%20who%20were%20later%20crowned%20the%20champions.%0D%0A%0D%0AThe%20event%20was%20attended%20by%20Member%20of%20Parliament%20for%20Uzumba%2C%20Simbaneuta%20Mudarikwa%2C%20traditional%20chiefs%2C%20civic%20leaders%20and%20veteran%20sports%20commentator%20Charles%20Mabika%2C%20who%20did%20the%20commentary%20of%20the%20final%20match%20of%20the%20tournament.%0D%0A%0D%0AIn%20an%20interview%20on%20the%20sidelines%20of%20the%20event%2C%20the%20Mdhara%20Vachauya%20hitmaker%20said%20more%20projects%20under%20the%20Tadzoka%20Kumusha%20initiative%20were%20in%20the%20pipeline%20%20as%20he%20endeavours%20to%20make%20a%20better%20tomorrow%20for%20everyone%20in%20his%20rural%20community%20and%20Africa%20at%20large.%0D%0A%0D%0A%0D%0A%0D%0ACommunity%20and%20traditional%20leaders%20hailed%20Jah%20Prayzah%20for%20the%20gesture%2C%20saying%20the%20musician%20was%20a%20true%20role%20model%20in%20Uzumba.%0D%0A%0D%0AJah%20Prayzah%20said%20it%20was%20a%20dream%20come%20true%20to%20host%20the%20tournament%20after%20months%20of%20planning.%0D%0A%0D%0A%E2%80%9CGiving%20back%20to%20a%20community%20and%20the%20people%20who%20paved%20the%20way%20for%20you%20is%20always%20a%20joy.%20I%20am%20really%20honoured%20to%20host%20the%20first%20of%20many%20Jah%20Prayzah%20soccer%20tournaments%20for%20schools%20here.%20I%20have%20always%20dreamt%20of%20the%20day%20I%20would%20get%20to%20spend%20time%20with%20the%20kids.%20It%20is%20my%20hope%20and%20wish%20that%20one%20or%20two%20of%20them%20will%20be%20inspired%20to%20take%20this%20initiative%20further%20when%20they%20grow%20up%2C%E2%80%9D%20he%20said.%0D%0A%0D%0A%E2%80%9CThe%20smiles%20on%20the%20kids%E2%80%99%20faces%20will%20definitely%20push%20for%20more%20works%20and%20projects%20from%20us%20for%20them.%20Like%20the%20saying%20goes%2C%20%E2%80%98honour%20your%20father%20and%20mother%20so%20that%20your%20days%20on%20earth%20may%20be%20increased%E2%80%99.%20For%20us%2C%20it%20is%20not%20only%20limited%20to%20your%20parents%2C%20but%20basically%20where%20you%20come%20from%20and%20just%20remembering%20your%20roots.%E2%80%9D%0D%0A%0D%0A%0D%0A%0D%0AMudarikwa%20saluted%20Jah%20Prayzah%20and%20urged%20the%20pupils%20to%20emulate%20what%20the%20dreadlocked%20musician%20did%20for%20the%20community.%0D%0A%0D%0A%E2%80%9CJah%20Prayzah%20is%20a%20product%20of%20this%20school%20and%20I%20want%20to%20thank%20him%20for%20such%20an%20initiative%20as%20he%20has%20remembered%20the%20importance%20of%20his%20former%20school%20at%20a%20time%20when%20many%20of%20the%20former%20students%20have%20not%20returned%20back%2C%E2%80%9D%20he%20said.%0D%0A%0D%0AHe%20challenged%20pupils%20to%20take%20sports%20seriously%20and%20desist%20from%20taking%20drugs%2C%20which%20he%20said%20destroys%20their%20future.%0A&tf=1" target="_blank"
					   class="wpusb-button-popup wpusb-gmail-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Send by Gmail"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-gmail wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Gmail"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="tg://msg_url?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&text=Jah%20Prayzah%20retraces%20his%20roots" target="_blank"
					   class="wpusb-button-popup wpusb-telegram-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Telegram"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-telegram wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Telegram"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="https://web.skype.com/share?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&text=Jah%20Prayzah%20retraces%20his%20roots" target="_blank"
					   class="wpusb-button-popup wpusb-skype-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Skype"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-skype wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Skype"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="viber://forward?text=Jah%20Prayzah%20retraces%20his%20roots%20☛%20https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
					   class="wpusb-button-popup wpusb-viber-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Viber"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-viber wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Viber"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="http://victorfreitas.github.io/wpupper-share-buttons/?href=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
					   class="wpusb-button-popup wpusb-like-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Like on Facebook"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-like wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Like"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&title=Jah%20Prayzah%20retraces%20his%20roots" target="_blank"
					   class="wpusb-button-popup wpusb-reddit-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Reddit"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-reddit wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Reddit"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="https://share.flipboard.com/bookmarklet/popout?v=2&ext=WPUpper%20Share%20Buttons&title=Jah%20Prayzah%20retraces%20his%20roots&url=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
					   class="wpusb-button-popup wpusb-flipboard-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Share on Flipboard"
					   
					   data-action="open-popup">

						<i class="wpusb-icon-flipboard wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Flipboard"></span>
					</a>
				</div>				<div class="wpusb-element-popup">
					<a href="https://www.facebook.com/dialog/send?app_id=140586622674265&link=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F&redirect_uri=https%3A%2F%2Fwww.thestandard.co.zw%2F2017%2F05%2F28%2Fjah-prayzah-retraces-roots%2F" target="_blank"
					   class="wpusb-button-popup wpusb-messenger-popup"
					   target="_blank"
					   rel="nofollow"
					   title="Send on Facebook Messenger"
					   
					   >

						<i class="wpusb-icon-messenger wpusb-icon-popup"></i>
						<span class="wpusb-name-popup" data-name="Messenger"></span>
					</a>
				</div></div><!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-2').gslider({ groupid: 2, speed: 12000 });
	jQuery('.g-3').gslider({ groupid: 3, speed: 15000 });
	jQuery('.g-4').gslider({ groupid: 4, speed: 12000 });
	jQuery('.g-5').gslider({ groupid: 5, speed: 12000 });
	jQuery('.g-6').gslider({ groupid: 6, speed: 12000 });
}
});
</script>
<!-- /AdRotate JS -->

</body>
</html>